<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<meta charset="utf-8" />
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-26466179-3", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");</script>
<meta name="title" content="Burl Ercell Parks | The Clayton Tribune, Rabun County, GA" />
<link rel="canonical" href="http://www.theclaytontribune.com/obituaries/burl-ercell-parks" />
<meta name="description" content="Burl Ercell Parks, age 68, of Sky Valley, Georgia, passed away on Oct. 30, 2019. " />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="text/javascript">
// Initialize the google variables.
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
// Add a place to store the slot name variable.
googletag.slots = googletag.slots || {};
(function() {
  var useSSL = "https:" == document.location.protocol;
  var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
  document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
  
  googletag.slots["cni_claytonsidebar3"] = googletag.defineSlot("//116205717/CNI-Claytonsidebar3", [300, 250], "js-dfp-tag-cni_claytonsidebar3")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_claytonsidebar2"] = googletag.defineSlot("//116205717/CNI-Claytonsidebar2", [300, 250], "js-dfp-tag-cni_claytonsidebar2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_claytonmarketplace"] = googletag.defineSlot("//116205717/CNI-Claytonmarketplace", [300, 100], "js-dfp-tag-cni_claytonmarketplace")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_claytonobitsidebar"] = googletag.defineSlot("//116205717/CNI-Claytonobitsidebar", [300, 250], "js-dfp-tag-cni_claytonobitsidebar")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_claytonleaderboard"] = googletag.defineSlot("//116205717/CNI-claytonleaderboard", [[728, 90], [320, 50]], "js-dfp-tag-cni_claytonleaderboard")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
      googletag.pubads().enableAsyncRendering();
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
      });
googletag.enableServices();
</script>
<link rel="shortcut icon" href="/sites/theclaytontribune.etypegoogle7.com/files/claytonfavicon.jpg" type="image/jpeg" />
<link rel="revision" href="http://www.theclaytontribune.com/obituaries/burl-ercell-parks" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>

<title>Burl Ercell Parks | The Clayton Tribune, Rabun County, GA</title>
<link rel="stylesheet" media="all" href="/core/assets/vendor/normalize-css/normalize.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/misc/normalize-fixes.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/ajax-progress.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/align.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/autocomplete-loading.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/fieldgroup.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/container-inline.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/clearfix.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/details.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/hidden.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/item-list.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/js.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/nowrap.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/position-container.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/progress.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/reset-appearance.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/resize.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/sticky-header.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-counter.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-counters.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-general-info.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tabledrag.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tablesort.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tree-child.module.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/modules/contrib/poll/css/poll.base.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/modules/contrib/poll/css/poll.theme.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/modules/custom/etype/css/etype.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/modules/custom/etype/modules/etype_login_cni/css/etype_login_cni.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/modules/contrib/addtoany/css/addtoany.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/node_modules/bulma-0.7.5/css/bulma.min.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/base.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/regions.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/typography.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/navigation.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/helpers.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/views.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/blocks.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/content.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/flexslider.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/ads.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/sites.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/themes/custom/tiemposcni/site.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/action-links.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/breadcrumb.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/button.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/collapse-processed.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/container-inline.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/details.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/exposed-filters.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/field.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/form.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/icons.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/inline-form.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/item-list.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/link.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/links.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/menu.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/more-link.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/pager.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tabledrag.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tableselect.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tablesort.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tabs.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/textarea.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/ui-dialog.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/messages.css?q0gqkj" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/node.css?q0gqkj" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Petrona" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Lato" />


<!--[if lte IE 8]>
<script src="/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->
<script src="/modules/custom/etype/js/ada_compliance.js?v=8.7.8"></script>

</head>
<body class="path-node page-node-type-article theclaytontribune">
<a href="#main-content" class="visually-hidden focusable skip-link">
    Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
      <div class="region region-large-ad">
    <div id="block-tiemposcni-dfptagcnidahlonegaleaderboard" class="block block-dfp block-dfp-adc71767df-ffb1-41f8-8438-70b6a790ce71">
  
    
      <div id="js-dfp-tag-cni_claytonleaderboard">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_claytonleaderboard');
        });
    </script>
</div>

  </div>

  </div>

<div class="layout-container">
  <div class="container is-widescreen">
    
    <header role="banner" class="columns">
        <div class="region region-header-left column">
    <div id="block-tiemposcni-date" class="block block-etype block-date-block">
  
    
      
<p class="is-size-7">November 11, 2019</p>
<div><a role="button" class="navbar-burger is-hidden-desktop" aria-label="menu" aria-expanded="false"><i class="fas fa-bars"></i></a></div>
    
    <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
  </div>
<div id="block-extendedsearch" class="block block-block-content block-block-content07777d42-1cac-44fc-9887-5bd2e95cec3a">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><a href="https://theclaytontribune.newsbank.com/">Extended Search</a></p></div>
      
  </div>

  </div>

        <div class="region region-header-center column">
    <div id="block-tiemposcni-branding" class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/theclaytontribune.etypegoogle7.com/files/download_asset_4.jpg" alt="The Clayton Tribune, Rabun County, GA Home" />
    </a>
  </div>

  </div>

        <div class="region region-header-right column">
      
        <div class="user-menu navbar-menu is-active is-paddingless is-shadowless is-hidden-touch">
            <a href="https://etypeservices.com/ReadTheEdition.aspx?Username=cryoder&amp;Pub=3055&amp;PType=TCTN3055XNTCTC" target="_blank" id="etype_login_cni_e_edition" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">E-edition</a>
            <a href="https://www.etypeservices.com/Subscriber/SignIn.aspx?IssueID=213428&amp;ReturnUrl=https%3A//www.etypeservices.com/Subscriber/ReSubscribe.aspx" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Renew</a>
            <a href="/etype-login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="etype-login">Log In</a>
            <a href="/user/login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="user/login">Log in</a>
            <a href="https://etypeservices.com/The%20Clayton%20TribuneID566/default.aspx?PubID=3055" target="_blank" id="etype_login_cni_subscribe" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Subscribe</a>
        </div>
  





  </div>

    </header>

    
      <div class="region region-navigation columns">
      <nav role="navigation" id="main-nav" aria-label="user navigation" class="column">
    <div class="navbar">
                <div class="navbar-start is-really-invisible columns">
            <div class="column">
                                <a role="button" class="navbar-burger is-active" aria-label="menu" aria-expanded="false"><i class="fas fa-times"></i></a>
                                <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
                <div id="mobile-nav">
                                                                <a href="https://etypeservices.com/The%20Clayton%20TribuneID566/" class="navbar-item">E-Edition</a>
                                                                                                        <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                            
                                                                    <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                    <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                    <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                    <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                    <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                    <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                                                                                                        <a href="https://classadz.vdata.com/CommunityNewspapersCornelia/Advertising/Advertiser/" class="navbar-item">Place a classified</a>
                                            
                                                                    <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                    <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                                                                                                        <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                    <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                    <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                            
                                                                    <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                                                        <a href="https://nearme.theclaytontribune.com/" class="navbar-item">Marketplace</a>
                                            
                                                                    <a href="http://www.etypeservices.com/The%20Clayton%20TribuneID566/default.aspx?PubID=3055" class="navbar-item">Subscribe</a>
                                                                                </div>
            </div>
            <div class="column">
                <div class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/theclaytontribune.etypegoogle7.com/files/download_asset_4.jpg" alt=" Home" />
    </a>
  </div>

            </div>
            <div class="column">&nbsp;</div>
        </div>
                <div id="main-navbar-menu" class="navbar-menu has-text-weight-semibold">
                                                                                                                                                        <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="https://etypeservices.com/The%20Clayton%20TribuneID566/" class="navbar-item">E-Edition</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                                                                                                            <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                                                                                                            <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                                                                                                            <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                                                                                                            <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://classadz.vdata.com/CommunityNewspapersCornelia/Advertising/Advertiser/" class="navbar-item">Place a classified</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                                                                                                                            <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                                                                                                                            <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://nearme.theclaytontribune.com/" class="navbar-item">Marketplace</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="http://www.etypeservices.com/The%20Clayton%20TribuneID566/default.aspx?PubID=3055" class="navbar-item">Subscribe</a>
                                                                                                    
                    </div>
                <div class="navbar-end">
              <a href="https://www.facebook.com/claytonnews/?rf=367109280156994" class="has-text-grey-dark" target="_blank" aria-label="Facebook"><i class="fab fa-facebook is-size-3"></i><span class="sr-only">facebook</span></a>

        </div>
    </div>
</nav>




  </div>

    
    
      <div class="region region-top-content">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>


    <main role="main" class="columns">
      <a id="main-content" tabindex="-1"></a>
                <div class="region region-content column">
    <div id="block-pagetitle" class="block block-core block-page-title-block">
  
    
      
  <h1 class="title"><span property="schema:name" class="field field--name-title field--type-string field--label-hidden">Burl Ercell Parks</span>
</h1>


  </div>
<div id="block-tiemposcni-content" class="block block-system block-system-main-block">
  
    
      

<article data-history-node-id="3092" role="article" about="/obituaries/burl-ercell-parks" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-full obituaries">
  
      <span property="schema:name" content="Burl Ercell Parks" class="rdf-meta hidden"></span>


      <footer class="node__meta">
      <article typeof="schema:Person" about="/user/16" class="profile">
  </article>

      <div class="node__submitted">
        By <span rel="schema:author" class="field field--name-uid field--type-entity-reference field--label-hidden"><a title="View user profile." href="/user/16" lang="" about="/user/16" typeof="schema:Person" property="schema:name" datatype="">News Staff</a></span>
 on Wednesday, November 6, 2019
          <span property="schema:dateCreated" content="2019-11-06T21:37:06+00:00" class="rdf-meta hidden"></span>

      </div>
    </footer>
  
  <div class="node__content">
                  
  <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-visually_hidden">
    <div class="field__label visually-hidden">Body</div>
              <div property="schema:text" class="field__item"><p>Burl Ercell Parks, age 68, of Sky Valley, Georgia, passed away on Oct. 30, 2019. </p>

<p>Burl was born the son of the late Ercell F. Parks and the late Elizabeth Louise Lovett Parks-McCathern on July 31, 1951 In Greenwood, South Carolina. </p>

<p> Burl was a Christian and a member the Rabun Gap Presbyterian Church. He was the past Rotary president, the Vice President of the Sid Weber Memorial Cancer Fund. He was a Master Mason, raised in Dougherty Lodge 591 and dual member of Rabun Gap lodge 265. He was a 32-Degree Member of the Valley of Albany Scottish Rite, and a member of the Hasan Shrine. He and his wife owned and operated Appalachian Insurance Agency. Burl earned the Chartered Life Underwriter and Chartered Financial Consultant from The American College in Brynmar, PA. He was a member of the Rabun County American Legion. He was also one of the first licensed EMT in the State of Georgia. When not busy with any one of these various responsibilities, he enjoyed working in his yard, and woodworking. </p>

<p>In addition to his father and mother, Burl was preceded in death by, one son, Burl E. Parks Jr.</p>

<p>His survivors include his loving wife, Carolyn McBurnett Parks; his son, Bryan Parks (Tanya), of Kennesaw, Georgia; half sister, Patricia Parks Bumgarner, of Lake City, Florida; four grandchildren, Brittany Parks  Lay (Michael), of Mountain City, Christopher Parks (Brittney), Benjamin Parks, Brandon Parks; four great-grandchildren, Lillianna Porter, Ezekiel Porter, Malachi Lay, Titus Lay. </p>

<p>A funeral service was held on Friday November 1, 2019 at 11 a.m. at the Rabun Gap Presbyterian Church with Rev. Don Barber officiating. </p>

<p>A graveside service was held on Saturday November 2, 2019 at the Crown Hill Cemetery, in Albany,  with Rev. Don Barber officiating. </p>

<p> The family asks that in lieu of flowers, donations be made in Burl’s memory to the Sid Weber Memorial Cancer Fund P.O. Box 485 Rabun Gap, Ga. 30568, The Community Pantry of Rabun County P.O. Box 1067, Clayton, GA 30525 or Paws 4 Life 261 Boen Creek Rd, Tiger, Ga. 30576.</p>

<p>Beck Funeral Home, in Clayton, Georgia, is in charge of the arrangements. If there are any questions, please call 706-782-9599. An online Memorial Register Book is available at <a href="http://www.beckfuneralhome.com/">www.beckfuneralhome.com</a>.</p></div>
          </div>
<span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://www.theclaytontribune.com/obituaries/burl-ercell-parks" data-a2a-title="Burl Ercell Parks"><a class="a2a_button_facebook"></a><a class="a2a_button_twitter"></a></span>
            </div>

</article>

  </div>

  </div>

      
                <aside class="region region-sidebar column layout-sidebar"  role="complementary">
    <div id="block-dfptagcniclaytonobitsidebar" class="block block-dfp block-dfp-adb8ce8898-4b9e-4c36-85e9-293a59578434">
  
    
      <div id="js-dfp-tag-cni_claytonobitsidebar">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_claytonobitsidebar');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-etypeeedition" class="block block-etype block-etype-block">
  
    
      
<div><a href="https://etypeservices.com/The%20Clayton%20TribuneID566/" target="_blank" aria-label="The Clayton Tribune, Rabun County, GA e-Edition"><img src="https://etypeservices.com/LandingPageImages/The%20Clayton%20Tribune/currentpg1.jpg" alt="The Clayton Tribune, Rabun County, GA e-Edition"></a></div>
<p><a href="https://etypeservices.com/The%20Clayton%20TribuneID566/" target="_blank" aria-label="The Clayton Tribune, Rabun County, GA e-Edition">Read The Clayton Tribune, Rabun County, GA</a></p>

  </div>
<div id="block-dfptagcniclaytonmarketplace" class="block block-dfp block-dfp-adc4a1b8ad-83d6-4f4c-a162-6309295445e5">
  
    
      <div id="js-dfp-tag-cni_claytonmarketplace">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_claytonmarketplace');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcniclaytonsidebar2" class="block block-dfp block-dfp-adc0139eb7-26eb-42e5-b7d6-4faf9bae065d">
  
    
      <div id="js-dfp-tag-cni_claytonsidebar2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_claytonsidebar2');
        });
    </script>
</div>

  </div>
<div id="block-weatherwidget-2" class="block block-etype block-weatherwidget-block weatherwidget">
      <iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=112114" frameborder="0" scrolling="no"></iframe>

  </div>
<div id="block-tiemposcni-popularcontent" role="navigation" class="block block-statistics block-statistics-popular-block">
  
      <h3 class="section-tag-heading">Popular content</h3>
    
      <div class="item-list"><h3>Today's:</h3><ul><li><a href="/sports/twin-rivers-challenge-raises-over-80000-scholarships" hreflang="en">Twin Rivers Challenge raises over $80,000 for scholarships</a></li><li><a href="/local-news/cannon-building-old-clayton-inn-projects-appear-be-hold" hreflang="en">Cannon building, Old Clayton Inn projects appear to be on hold</a></li><li><a href="/regional/mountain-traveler-all-aboard-wine-tour" hreflang="en">MOUNTAIN TRAVELER: All aboard a wine tour</a></li></ul></div><br /><div class="item-list"><h3>All time:</h3><ul><li><a href="/forest-lands-sale-rabun" hreflang="en">Forest lands for sale in Rabun?</a></li><li><a href="/clayton-hosting-bicentennial-fireworks-aug-31" hreflang="en">Clayton hosting Bicentennial fireworks Aug. 31</a></li><li><a href="/dillard-festival-may-be-rabuns-best-kept-secret" hreflang="en">Dillard festival may be Rabun&#039;s best-kept secret</a></li></ul></div><br /><div class="item-list"><h3>Last viewed:</h3><ul><li><a href="/local-news/community-helps-stuff-truck-local-food-bank-drive" hreflang="en">Community helps &#039;Stuff The Truck&#039; for local Food Bank Drive</a></li><li><a href="/local-links" hreflang="en">Local Links</a></li><li><a href="/local-news/dui-charges-filed-after-collision" hreflang="en">DUI charges filed after collision</a></li></ul></div><br />
  </div>
<div id="block-dfptagcniclaytonsidebar3" class="block block-dfp block-dfp-adcb58af92-f9a9-43d0-b215-e3cf929cf442">
  
    
      <div id="js-dfp-tag-cni_claytonsidebar3">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_claytonsidebar3');
        });
    </script>
</div>

  </div>

  </aside>

      
    </main>

    <footer role="contentinfo" class="columns border-top-light">
                <div class="region region-footer-left column">
    <div id="block-tiemposcni-contactinformation" class="block block-block-content block-block-contentbb8e208a-8245-4087-b0c0-a5b20e5a2929">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><strong>The Clayton Tribune</strong></p>

<p><strong>Mailing Address:</strong><br />
P.O. Box 425, 120 North Main Street<br />
Clayton, GA 30525</p>

<p><strong>Phone:</strong> 706-782-3312<br /><strong>Fax:</strong> 706-782-4230<br /><strong>Email:</strong><a href="mailto:thetribune@theclaytontribune.com"> thetribune@TheClaytonTribune.com</a></p></div>
      
  </div>

  </div>

                      <div class="region region-footer-center column">
    <div id="block-tiemposcni-copyrightnotice" class="block block-etype block-copyright-block">
  
    
      <p class="has-text-centered">&copy;&nbsp;2019&nbsp;The Clayton Tribune, Rabun County, GA</p>
  </div>

  </div>

                      <div class="region region-footer-right column">
      
    <ul class="menu footer-menu is-pulled-right">
          <li class="menu-item">
      <a href="/etype-login" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="etype-login">Login</a>
    </li>
          <li class="menu-item">
      <a href="https://nearme.theclaytontribune.com/" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Marketplace</a>
    </li>
          <li class="menu-item">
      <a href="/contact" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="contact">Contact</a>
    </li>
          <li class="menu-item">
      <a href="/webforms" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="webforms">Webforms</a>
    </li>
          <li class="menu-item">
      <a href="/about" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/969">About Us</a>
    </li>
          <li class="menu-item">
      <a href="/archives" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/973">Archive</a>
    </li>
          <li class="menu-item">
      <a href="https://etypeservices.com/The%20Clayton%20TribuneID566/" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">E-Edition</a>
    </li>
          <li class="menu-item">
      <a href="/local-links" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1259">Local Links</a>
    </li>
          <li class="menu-item">
      <a href="/ada-compliance" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="ada-compliance">Accessibility Policy</a>
    </li>
  </ul>
  





  </div>

          </footer>

    <section id="coupons" class="columns">
          </section>

  </div>
</div>
  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/3092","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","google_analytics":{"trackOutbound":true,"trackMailto":true,"trackDownload":true,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"statistics":{"data":{"nid":"3092"},"url":"\/core\/modules\/statistics\/statistics.php"},"user":{"uid":0,"permissionsHash":"a9bb809a72593f7676c735244b1ad31eea510cca2f0f7ee6320c17079314de37"}}</script>
<script src="/core/assets/vendor/domready/ready.min.js?v=1.0.8"></script>
<script src="/core/assets/vendor/jquery/jquery.min.js?v=3.2.1"></script>
<script src="/core/assets/vendor/jquery/jquery-extend-3.4.0.js?v=3.2.1"></script>
<script src="/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.2.0"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=8.7.8"></script>
<script src="/core/misc/drupal.js?v=8.7.8"></script>
<script src="/core/misc/drupal.init.js?v=8.7.8"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/modules/contrib/addtoany/js/addtoany.js?v=8.7.8"></script>
<script src="/libraries/js.cookie.js?v=2.2.0"></script>
<script src="/modules/custom/etype/modules/etype_login_cni/js/etype_login_cni_page.js?v=8.7.8"></script>
<script src="/modules/contrib/google_analytics/js/google_analytics.js?v=8.7.8"></script>
<script src="/themes/custom/tiempos/js/theme.js?v=8.7.8"></script>
<script src="//use.fontawesome.com/releases/v5.8.1/js/all.js" defer></script>
<script src="/core/modules/statistics/statistics.js?v=8.7.8"></script>
<script src="/themes/custom/tiempos/js/article.js?v=8.7.8"></script>

<script data-cfasync="false" type="text/javascript">(function(s,o,l,v,e,d){if(s[o]==null&&s[l+e]){s[o]="loading";s[l+e](d,l=function(){s[o]="complete";s[v+e](d,l,!1)},!1)}})(document,"readyState","add","remove","EventListener","DOMContentLoaded");(function(){var s=document.createElement("script");s.type="text/javascript";s.async=true;s.src="//cdn.engine.liondigitalserving.com/Scripts/infinity.js.aspx?guid=5f42ad44-8ae3-4caa-a45d-1a3ca4c99bfd";s.id="infinity";s.setAttribute("data-guid","5f42ad44-8ae3-4caa-a45d-1a3ca4c99bfd");s.setAttribute("data-version","async");var e=document.getElementsByTagName('script')[0];e.parentNode.insertBefore(s,e)})();</script>
</body>
</html>
